Case History Display Issue in Mission Control

Incident Report for Mission Cloud Service Inc.

Resolved

This incident has been resolved.
Posted Jul 30, 2025 - 07:35 PDT

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Jul 30, 2025 - 07:18 PDT

Update

Our vendor has identified a root cause and is actively working to deploy a software upgrade. We’ll share an update once resolved. Thank you for your patience.
Posted Jul 29, 2025 - 15:14 PDT

Identified

We're aware of an issue affecting some users where case history may not display properly in Mission Control. Our team is working with our vendor to resolve it as quickly as possible.
This issue only impacts case history visibility. Replies are still received by our Operations team and handled as usual.
We’ll share an update once resolved. Thank you for your patience.
Posted Jul 24, 2025 - 11:08 PDT
This incident affected: Mission Control and Core Services.