Ticketing system currently unavailable
Incident Report for Mission Cloud Service Inc.
Resolved
All issues have been resolved and ServiceNow is now fully operational.
Posted Oct 10, 2022 - 11:03 PDT
Monitoring
ServiceNow is now operational and we're monitoring its performance.
Posted Oct 10, 2022 - 10:39 PDT
Update
ServiceNow's subject matter experts are working to divert traffic from the impacted ISP to alternate service providers
Posted Oct 10, 2022 - 10:27 PDT
Investigating
ServiceNow is currently unavailable due to a vendor outage. ISM team is working with the vendor to restore the services.

Case response times might be impacted by this. For urgent issues, don't hesitate to reach out to our support line at 855-647-7466 x2.
Posted Oct 10, 2022 - 10:07 PDT
This incident affected: Mission Control and Core Services.