Mission Control and supporting backend services

Incident Report for Mission Cloud Service Inc.

Resolved

This incident has been resolved.
Posted Sep 03, 2026 - 17:50 PDT

Identified

AWS has identified an issue with their STS Service for the US-West-2 (Oregon) Region. Mission Control remains online, however features that rely on generating temporary AWS credentials may experience unexpected behavior.
Posted Sep 03, 2026 - 15:00 PDT
This incident affected: Mission Control and Core Services.