Degraded Performance for Mission Control
Incident Report for Mission Cloud Service Inc.
Resolved
AWS has indicated that the Lambda service, which they found to be the root cause, is functional again and processing the backlog of jobs that accumulated during their service interruption.

For additional information, please see the AWS Health Dashboard.
https://health.aws.amazon.com/health/status
Posted Jun 13, 2023 - 14:43 PDT
Monitoring
AWS has indicated that they are starting to see recovery in their services.

Mission will continue to monitor the impact against Mission Control and our Core Services which support it.

For additional information, please see the AWS Health Dashboard.
https://health.aws.amazon.com/health/status
Posted Jun 13, 2023 - 14:07 PDT
Identified
AWS has identified a service outage with one or more of its services.
Please follow the AWS Status Page for additional information.

https://health.aws.amazon.com/health/status
Posted Jun 13, 2023 - 12:12 PDT
Investigating
We have identified an issue with our 3rd Party Provider, Amazon Web Services. General availability of the AWS Management console and several AWS Services appear to be impacted.
Posted Jun 13, 2023 - 12:10 PDT
This incident affected: Mission Control and Core Services.